របៀបបង្ខំអោយឧបករណ៍ប្រើ DNS របស់ Router

បន្ទាប់ពីបានដាក់បញ្ចូល DNS ទៅក្នុងការកំណត់រប់ស router របស់អ្នករួច ឧបករណ៍ទាំងអស់នៅក្នុង local network នឹងត្រូវប្រើ DNS នោះ។ តែមានករណីខ្លះដែលអ្នកប្រើប្រាស់ឧបករណ៍បានធ្វើការកំណត់ទៅលើឧបករណ៍របស់ពួកគេអោយប្រើ DNS ផ្សេង។ ដូច្នេះយើងត្រូវបង្ខំអោយឧបករណ៍ទាំងអស់ដែលនៅក្នុង local network ប្រើ DNS ដែលបានកំណត់ដោយ router។ សូមបញ្ជាក់ផងដែរថាមិនមែនគ្រប់ router ទាំងអស់សុទ្ធតែអាចធ្វើបែបនេះបានទេ ហើយមួយទៀតគឺថាបើសិនជាអ្នកប្រើប្រាស់មានចំណេះដឹងច្រើនផ្នែកបណ្ដាញ network ពួកគេអាចប្រើ proxy ឬ VPN ដើម្បីជៀសពីDNS ដែលបានកំណត់ដោយ router បាន។ ប៉ុន្តែមិនមែនអ្នកប្រើប្រាស់គ្រប់គ្នាសុទ្ទតែអាចធ្វើបែបនេះបាននោះទេ។ Router ដែលត្រូវយកមកបង្ហាញក្នុងអត្ថបទនេះមាន២ម៉ូឌែលគឺ Mikrotik RB750Gr3 និង TP-Link TL-WR1043ND។ ខាងក្រោមនេះជារបៀបបង្ខំអោយឧបករណ៍ទាំងអស់ប្រើ DNS ដែលកំណត់ដោយ router។

Mikrotik RB750Gr3 (RouterOS 6.42.5)

១. ចូលទៅកាន់ Mikrotik router របស់អ្នកដែលជាទូទៅមានអាសយដ្ឋាន 192.168.88.1 តាមរយៈកម្មវិធី browser (Chrome, Firefox…) រួចវាយបញ្ចូលឈ្មោះអ្នកប្រើប្រាស់ និងពាក្យសំងាត់របស់អ្នក។

ចូលក្នុង Router

២. ចុចលើពាក្យ “Terminal” ដូចដែលបានបង្ហាញក្នុងរូបខាងក្រោម៖

ចុចលើពាក្យ “Terminal”

៣. វាយបញ្ចូល command ដូចខាងក្រោម៖

/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=tcp dst-port=53
/ip firewall nat add chain=dstnat action=dst-nat to-addresses=192.168.88.1 to-ports=53 protocol=udp dst-port=53

ការវាយបញ្ចូល commands ទាំងនេះគឺដើម្បីបង្ខំអោយឧបករណ៍នៅក្នុង local network ទាំងអស់អោយ ប្រើ DNS ដែលបានកំណត់ដោយ router មានន័យថាឧបករណ៍ទាំងឡាយណាដែលប្រើ DNS ផ្សេងនឹងត្រូវបានបង្វែទិសដៅមករក DNS របស់ router វិញ។ ដូច្នេះឧបករណ៍ទាំងនោះនឹងមិនបាត់បង់ការភ្ជាប់ទៅអិុនធឺណិតនោះទេ។ នៅត្រង់ចំនុចនេះ port 53 គឺជាចំនុចសំខាន់ព្រោះវាគឺជា port តែមួយគត់សំរាប់ដំណើការរបស់ DSN។

៤. Reboot router របស់អ្នកជាការស្រេច។

TP-Link TL-WR1043ND

សំរាប់ TP-Link router គឺខុសពី Mikrotik router ត្រង់ថាបន្ទាប់ពីបានធ្វើការបង្ខំរួច ឧបករណ៍ទាំងឡាយណាដែលបានធ្វើការកំណត់ DNS ផ្សេងពី router នឹងមិនអាចភ្ជាប់ទៅកាន់អិុនធឺណិតបានទេ។ អ្នកប្រើប្រាស់ត្រូវធ្វើការកែប្រែការកំណត់របស់ឧបករណ៍របស់ពួកគេមករកសភាពដើម ឬដោយស្វ័យប្រវត្តិវិញ (default or automatic) ដើម្បីអាចភ្ចាប់អិុនធឺណិតបាន។ ខាងក្រោមនេះគឺរបៀបធ្វើការកំណត់ TP-Link router។

១. ចូលទៅកាន់ TP-link router របស់អ្នកដែលជាទូទៅមានអាសយដ្ឋាន 192.168.1.1 ឬ 192.168.0.1 រួចវាយបញ្ចូលឈ្មោះអ្នកប្រើប្រាស់ និងពាក្យសំងាត់របស់អ្នក។ 

២. ធ្វើតាមរូបខាងក្រោមដើម្បីបង្កើត host។

(Host គឺជាសំណុំអាសយដ្ឋានអិុនធឺណិតក្នុងតំបន់ (local IP address) ដែលហ្នឹងត្រូវគោរពតាមច្បាប់ (rule) ដែលយើងនឹងបង្កើតនៅក្នុងជំហ៊ានបន្ទាប់។ ក្នុងករណីនេះ យើងនឹងបង្កើតសំណុំមួយដែលក្ដោបយកគ្រប់អាសយដ្ឋានអិុនធឺណិតក្នុងតំបន់ទាំងអស់ដែលមានតាំងពី 192.168.1.1 រហូតដល់ 192.168.1.254។ ដូច្នេះនឹងគ្មានឧបករណ៍ណាអាចគេចផុតពីច្បាប់របស់យើងឡើយ។)

៣. ធ្វើតាមរូបខាងក្រោមដើម្បីបង្កើត target ចំនួន៤។ (Target អាចជាអាសយដ្ឋានសាធារណៈ (public IP address) ឬអាចជាគេហទំព័រ។ Target គឺជាគោលដៅដែលអាចអោយ host មានដំណើរការបាន មានន័យថា host មិនអាចមានដំណើរទៅកាន់ public IP ឬគេហទំព័រណាដែលមិនមាននៅក្នុង target នោះទេ។ ក្នុងករណីនេះ target របស់យើងគឺ 208.67.222.123 និង 208.67.220.123។)

៤. ធ្វើតាមរូបខាងក្រោមដើម្បីបង្កើត rule ចំនួន ៤។ (Rule គឺជាច្បាប់ដែលបានបង្កើតឡើងដើម្បីអោយ host អាចមានដំណើរការទៅកាន់ target ដែលបានកំណត់។)

យើងនឹងធ្វើការពន្យល់ពីច្បាប់ទាំង៤នៅខាងក្រោមនេះ៖

ច្បាប់ទី១ និងច្បាប់ទី២រួមបញ្ចូលគ្នាមានន័យថា សំរាប់ port 53 (ដែលជា port សំរាប់ DNS) host ទាំងអស់អាចមានដំណើរការទៅលើតែ DNS ដែលមាន pubic IP address 208.67.222.123 និង 208.67.220.123 តែប៉ុណ្ណោះ។

ច្បាប់ទី៣ និងច្បាប់ទី៤រួមបញ្ចូលគ្នាមានន័យថា host ទាំងអស់អាចមានដំណើរទៅលើគ្រប់ IP address ទាំងអស់សំរាប់ port ដទៃទៀតក្រៅពី port 53។

៥. ជាចុងក្រោយធ្វើការ reboot router របស់អ្នកដើម្បីអោយកំនែប្រែមានប្រសិទ្ធភាព៕